using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^a[a-z]+a$)|(^e[a-z]+e$)|(^i[a-z]+i$)|(^o[a-z]+o$)|(^u[a-z]u+$)";
string input = @"agdua";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}