re = /<(\w+)(?: \w+ ?= ?("|')?.*\2 ?)*(?:(?:>(?:.*)<\/\1>)|(?:\/>))/m
str = '<a href="https://example.com">Example</a>
<img src="https://example.com"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end