$re = '/<(\w+)(?: \w+ ?= ?("|\')?.*\2 ?)*(?:(?:>(?:.*)<\/\1>)|(?:\/>))/m';
$str = '<a href="https://example.com">Example</a>
<img src="https://example.com"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);