using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)(?: \w+ ?= ?(""|')?.*\2 ?)*(?:(?:>(?:.*)<\/\1>)|(?:\/>))";
string input = @"<a href=""https://example.com"">Example</a>
<img src=""https://example.com""/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}