$re = '/^((CAPR?I?\s?SUN\b)|(CAPRI\b)|(C\W?S\b)|(JUICES?\b)|(STRAWBERRY\b))/m';
$str = 'C/S ARIETY PACK 40CT CS C/S
CAPRI SN SPR V FRTPNCH 10PK
CAPRI SN SPR V JCE APPLE 10PK
CAPRI SN SPR V JCE BERRY 10PK
CAPRI STRAWNANA MINIONS CAPRI
CAPRI SUN100% JUICE APPLE SPL
CAPRI SUN 100% JUICE BERRY BRE
CAPRI SUN 100% JUICE FRUIT DIV
CAPRI SUN 100% JUICE GRAPE TID
CAPRI SUN 40CT 100% JUICE VAR
CAPRI SUN 40CT ROARING WATERS
CAPRI SUN 40CT VARIETY PACK
CAPRI SUN COOL 40 CT
CAPRI SUN FRT PNCH SPOUTED PCH
CAPRI SUN FRT PUNCH 30CT
CAPRI SUN FRUIT PUNCH
CAPRI SUN FRUIT/VEGGIE APPLE SWEET POTATO SMASH 10CT
CAPRI SUN FRUIT/VEGGIE PUNCH CARROT CRAZE 10PK
CAPRI SUN GRAPE
CAPRI SUN KWI SPOUTED PCH
CAPRI SUN LEMONADE
CAPRI SUN MOUNTAIN COOLER
CAPRI SUN ORANGE
CAPRI SUN ORGANIC APPLE 10PK
CAPRI SUN ORGANIC FRUIT PUNCH 10PK
CAPRI SUN ORGANIC GRAPE 10PK
CAPRI SUN ORGANIC TROPICAL PUNCH 10PK
CAPRI SUN PACIFIC COOLER
CAPRI SUN PACIFIC COOLER 30/6 OZ
CAPRI SUN RED BERRY
CAPRI SUN ROARIN WATER BERRY
CAPRI SUN ROARIN WATER GRAPE
CAPRI SUN ROARIN WATER STRAWBE
CAPRI SUN ROARIN WATER TROPICA
CAPRI SUN ROARIN WATER WILD CH
CAPRI SUN ROARING WATERS FRT P
CAPRI SUN SPLASH COOLER
CAPRI SUN STRAWBERRY
CAPRI SUN STRAWBERRY KIWI
CAPRI SUN STRW KIWI 30CT
CAPRI SUN SURF COOLER
CAPRI SUN TROPICAL PUNCH
CAPRI SUN WILD CHERRY
CAPRI SUN WLD CHRRY 30CT
CAPRISUN 100% JC
CAPRISUN ROARING WATERS TROPICAL FRUIT
CAPSUN COASTAL COOLER 10 pk
CAPSUN FRUIT PUNCH DRINK 10PK 10 ct
CAPSUN PACIFIC COOLER 10PK 10 ct
CS FRUIT PUNCH
JUICE FRT VEG BERRY/CARRT BLST
JUICES APPLE FRUIT REFRESHER
JUICES BERRY FRUIT REFRESHER
STRAWBERRY LEMONADE ORGANIC
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);