#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((CAPR?I?\s?SUN\b)|(CAPRI\b)|(C\W?S\b)|(JUICES?\b)|(STRAWBERRY\b))"
Local $sString = "C/S ARIETY PACK 40CT CS C/S" & @CRLF & _
"CAPRI SN SPR V FRTPNCH 10PK" & @CRLF & _
"CAPRI SN SPR V JCE APPLE 10PK" & @CRLF & _
"CAPRI SN SPR V JCE BERRY 10PK" & @CRLF & _
"CAPRI STRAWNANA MINIONS CAPRI" & @CRLF & _
"CAPRI SUN100% JUICE APPLE SPL" & @CRLF & _
"CAPRI SUN 100% JUICE BERRY BRE" & @CRLF & _
"CAPRI SUN 100% JUICE FRUIT DIV" & @CRLF & _
"CAPRI SUN 100% JUICE GRAPE TID" & @CRLF & _
"CAPRI SUN 40CT 100% JUICE VAR" & @CRLF & _
"CAPRI SUN 40CT ROARING WATERS" & @CRLF & _
"CAPRI SUN 40CT VARIETY PACK" & @CRLF & _
"CAPRI SUN COOL 40 CT" & @CRLF & _
"CAPRI SUN FRT PNCH SPOUTED PCH" & @CRLF & _
"CAPRI SUN FRT PUNCH 30CT" & @CRLF & _
"CAPRI SUN FRUIT PUNCH" & @CRLF & _
"CAPRI SUN FRUIT/VEGGIE APPLE SWEET POTATO SMASH 10CT" & @CRLF & _
"CAPRI SUN FRUIT/VEGGIE PUNCH CARROT CRAZE 10PK" & @CRLF & _
"CAPRI SUN GRAPE" & @CRLF & _
"CAPRI SUN KWI SPOUTED PCH" & @CRLF & _
"CAPRI SUN LEMONADE" & @CRLF & _
"CAPRI SUN MOUNTAIN COOLER" & @CRLF & _
"CAPRI SUN ORANGE" & @CRLF & _
"CAPRI SUN ORGANIC APPLE 10PK" & @CRLF & _
"CAPRI SUN ORGANIC FRUIT PUNCH 10PK" & @CRLF & _
"CAPRI SUN ORGANIC GRAPE 10PK" & @CRLF & _
"CAPRI SUN ORGANIC TROPICAL PUNCH 10PK" & @CRLF & _
"CAPRI SUN PACIFIC COOLER" & @CRLF & _
"CAPRI SUN PACIFIC COOLER 30/6 OZ" & @CRLF & _
"CAPRI SUN RED BERRY" & @CRLF & _
"CAPRI SUN ROARIN WATER BERRY" & @CRLF & _
"CAPRI SUN ROARIN WATER GRAPE" & @CRLF & _
"CAPRI SUN ROARIN WATER STRAWBE" & @CRLF & _
"CAPRI SUN ROARIN WATER TROPICA" & @CRLF & _
"CAPRI SUN ROARIN WATER WILD CH" & @CRLF & _
"CAPRI SUN ROARING WATERS FRT P" & @CRLF & _
"CAPRI SUN SPLASH COOLER" & @CRLF & _
"CAPRI SUN STRAWBERRY" & @CRLF & _
"CAPRI SUN STRAWBERRY KIWI" & @CRLF & _
"CAPRI SUN STRW KIWI 30CT" & @CRLF & _
"CAPRI SUN SURF COOLER" & @CRLF & _
"CAPRI SUN TROPICAL PUNCH" & @CRLF & _
"CAPRI SUN WILD CHERRY" & @CRLF & _
"CAPRI SUN WLD CHRRY 30CT" & @CRLF & _
"CAPRISUN 100% JC" & @CRLF & _
"CAPRISUN ROARING WATERS TROPICAL FRUIT" & @CRLF & _
"CAPSUN COASTAL COOLER 10 pk " & @CRLF & _
"CAPSUN FRUIT PUNCH DRINK 10PK 10 ct " & @CRLF & _
"CAPSUN PACIFIC COOLER 10PK 10 ct " & @CRLF & _
"CS FRUIT PUNCH" & @CRLF & _
"JUICE FRT VEG BERRY/CARRT BLST" & @CRLF & _
"JUICES APPLE FRUIT REFRESHER" & @CRLF & _
"JUICES BERRY FRUIT REFRESHER" & @CRLF & _
"STRAWBERRY LEMONADE ORGANIC" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")