import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((CAPR?I?\\s?SUN\\b)|(CAPRI\\b)|(C\\W?S\\b)|(JUICES?\\b)|(STRAWBERRY\\b))";
final String string = "C/S ARIETY PACK 40CT CS C/S\n"
+ "CAPRI SN SPR V FRTPNCH 10PK\n"
+ "CAPRI SN SPR V JCE APPLE 10PK\n"
+ "CAPRI SN SPR V JCE BERRY 10PK\n"
+ "CAPRI STRAWNANA MINIONS CAPRI\n"
+ "CAPRI SUN100% JUICE APPLE SPL\n"
+ "CAPRI SUN 100% JUICE BERRY BRE\n"
+ "CAPRI SUN 100% JUICE FRUIT DIV\n"
+ "CAPRI SUN 100% JUICE GRAPE TID\n"
+ "CAPRI SUN 40CT 100% JUICE VAR\n"
+ "CAPRI SUN 40CT ROARING WATERS\n"
+ "CAPRI SUN 40CT VARIETY PACK\n"
+ "CAPRI SUN COOL 40 CT\n"
+ "CAPRI SUN FRT PNCH SPOUTED PCH\n"
+ "CAPRI SUN FRT PUNCH 30CT\n"
+ "CAPRI SUN FRUIT PUNCH\n"
+ "CAPRI SUN FRUIT/VEGGIE APPLE SWEET POTATO SMASH 10CT\n"
+ "CAPRI SUN FRUIT/VEGGIE PUNCH CARROT CRAZE 10PK\n"
+ "CAPRI SUN GRAPE\n"
+ "CAPRI SUN KWI SPOUTED PCH\n"
+ "CAPRI SUN LEMONADE\n"
+ "CAPRI SUN MOUNTAIN COOLER\n"
+ "CAPRI SUN ORANGE\n"
+ "CAPRI SUN ORGANIC APPLE 10PK\n"
+ "CAPRI SUN ORGANIC FRUIT PUNCH 10PK\n"
+ "CAPRI SUN ORGANIC GRAPE 10PK\n"
+ "CAPRI SUN ORGANIC TROPICAL PUNCH 10PK\n"
+ "CAPRI SUN PACIFIC COOLER\n"
+ "CAPRI SUN PACIFIC COOLER 30/6 OZ\n"
+ "CAPRI SUN RED BERRY\n"
+ "CAPRI SUN ROARIN WATER BERRY\n"
+ "CAPRI SUN ROARIN WATER GRAPE\n"
+ "CAPRI SUN ROARIN WATER STRAWBE\n"
+ "CAPRI SUN ROARIN WATER TROPICA\n"
+ "CAPRI SUN ROARIN WATER WILD CH\n"
+ "CAPRI SUN ROARING WATERS FRT P\n"
+ "CAPRI SUN SPLASH COOLER\n"
+ "CAPRI SUN STRAWBERRY\n"
+ "CAPRI SUN STRAWBERRY KIWI\n"
+ "CAPRI SUN STRW KIWI 30CT\n"
+ "CAPRI SUN SURF COOLER\n"
+ "CAPRI SUN TROPICAL PUNCH\n"
+ "CAPRI SUN WILD CHERRY\n"
+ "CAPRI SUN WLD CHRRY 30CT\n"
+ "CAPRISUN 100% JC\n"
+ "CAPRISUN ROARING WATERS TROPICAL FRUIT\n"
+ "CAPSUN COASTAL COOLER 10 pk \n"
+ "CAPSUN FRUIT PUNCH DRINK 10PK 10 ct \n"
+ "CAPSUN PACIFIC COOLER 10PK 10 ct \n"
+ "CS FRUIT PUNCH\n"
+ "JUICE FRT VEG BERRY/CARRT BLST\n"
+ "JUICES APPLE FRUIT REFRESHER\n"
+ "JUICES BERRY FRUIT REFRESHER\n"
+ "STRAWBERRY LEMONADE ORGANIC\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}