// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(.*)\.(xls|xlsx|csv|tsv|odt)").unwrap();
let string = "cXdyORNyNzA0NDEzMjA_-?''9NmM_mJSIiNTM2FjUyeHd4fg.XLS
cXdyORNyNzA0NDEzMjA_-?''9NmM_mJSIiNTM2FjUyeHd4fg.csv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}