re = /^(.*)\.(xls|xlsx|csv|tsv|odt)/mi
str = 'cXdyORNyNzA0NDEzMjA_-?\'\'9NmM_mJSIiNTM2FjUyeHd4fg.XLS
cXdyORNyNzA0NDEzMjA_-?\'\'9NmM_mJSIiNTM2FjUyeHd4fg.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end