$re = '/^(.*)\.(xls|xlsx|csv|tsv|odt)/mi';
$str = 'cXdyORNyNzA0NDEzMjA_-?\'\'9NmM_mJSIiNTM2FjUyeHd4fg.XLS
cXdyORNyNzA0NDEzMjA_-?\'\'9NmM_mJSIiNTM2FjUyeHd4fg.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);