# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([+0]?[06]?)(?&sep)(36)?(?&sep)(?P<aera>1|[2-9][0-9])(?&sep)(?P<num>\d{3})(?&sep)(\d{2})(?'sep'[\)\(-\/\.x ]*){2}"
test_str = ("+36 20 800 8848 \n"
"36 1 267-5260 \n"
"+36 1 267 5260\n"
"+36 24 415 351\n"
"06 (24) 415 351\n"
"6(1)415 3510\n"
"00361-267-5260\n"
"0036-1-267-5260\n"
"0036-1-267-52-60\n"
"208008848\n"
"20800 88-48\n"
"00 34 800 828\n"
"((06)|[\\+0]{0,2}\\s*36)\n"
"[+0]{0,2}(?&sep)36")
subst = "$3$4$5$6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.