const regex = /([+0]?[06]?)(?&sep)(36)?(?&sep)(?P<aera>1|[2-9][0-9])(?&sep)(?P<num>\d{3})(?&sep)(\d{2})(?'sep'[\)\(-\/\.x ]*){2}/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+0]?[06]?)(?&sep)(36)?(?&sep)(?P<aera>1|[2-9][0-9])(?&sep)(?P<num>\\d{3})(?&sep)(\\d{2})(?\'sep\'[\\)\\(-\\\/\\.x ]*){2}', 'ig')
const str = `+36 20 800 8848
36 1 267-5260
+36 1 267 5260
+36 24 415 351
06 (24) 415 351
6(1)415 3510
00361-267-5260
0036-1-267-5260
0036-1-267-52-60
208008848
20800 88-48
00 34 800 828
((06)|[\\+0]{0,2}\\s*36)
[+0]{0,2}(?&sep)36`;
const subst = `$3$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);