// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<classname>[\w\.]+)?(?:#(?<member>\w+))?(?:\((?<params>.*)\))?(?:\s(?<label>\w+(?:\s\w+)*))?$").unwrap();
let string = "Moo#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType)
#withRecipientsWithDefaultName
Moo#withRecipientsWithDefaultName label
#withRecipientsWithDefaultName label
ClassName myLabel
ClassName#member
ClassName my label
ClassName
org.company.ClassName";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}