#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<classname>[\w\.]+)?(?:#(?<member>\w+))?(?:\((?<params>.*)\))?(?:\s(?<label>\w+(?:\s\w+)*))?$"
Local $sString = "Moo#withRecipientsWithDefaultName(String, Collection, RecipientType) label" & @CRLF & _
"#withRecipientsWithDefaultName(String, Collection, RecipientType) label" & @CRLF & _
"#withRecipientsWithDefaultName(String, Collection, RecipientType)" & @CRLF & _
"#withRecipientsWithDefaultName" & @CRLF & _
"Moo#withRecipientsWithDefaultName label" & @CRLF & _
"#withRecipientsWithDefaultName label" & @CRLF & _
"ClassName myLabel" & @CRLF & _
"ClassName#member" & @CRLF & _
"ClassName my label" & @CRLF & _
"ClassName" & @CRLF & _
"org.company.ClassName"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")