package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<classname>[\w\.]+)?(?:#(?<member>\w+))?(?:\((?<params>.*)\))?(?:\s(?<label>\w+(?:\s\w+)*))?$`)
var str = `Moo#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType) label
#withRecipientsWithDefaultName(String, Collection, RecipientType)
#withRecipientsWithDefaultName
Moo#withRecipientsWithDefaultName label
#withRecipientsWithDefaultName label
ClassName myLabel
ClassName#member
ClassName my label
ClassName
org.company.ClassName`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}