$re = '/{{([^0-9]\w+)/';
$str = '{{text}}=={{q113=="t123" ? "Active Product":" InActive"}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);