using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{([^0-9]\w+)";
string input = @"{{text}}=={{q113==""t123"" ? ""Active Product"":"" InActive""}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}