// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$").unwrap();
let string = "0.00
123.12k
123,123,123.12m
123,123,123,123.00b";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}