const regex = /^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{1,3}((\\,[0-9]{3})*)\\.[0-9]{2}[kmb]?$', 'gm')
const str = `0.00
123.12k
123,123,123.12m
123,123,123,123.00b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}