using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$";
string input = @"0.00
123.12k
123,123,123.12m
123,123,123,123.00b";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}