re = /^(\+|00)[0-9]*$/m
str = '+201000215350
00201000215350
201000215351
01000215350
1000215350
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end