package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+|00)[0-9]*$`)
var str = `+201000215350
00201000215350
201000215351
01000215350
1000215350
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}