$re = '/^(\+|00)[0-9]*$/m';
$str = '+201000215350
00201000215350
201000215351
01000215350
1000215350
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);