re = /^[A-Za-z]+\s*[A-Za-z]*(\*$)*/m
str = 'La*
Laura*
Laura Rese*
Laura Reseni
Laura Reseni*
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end