$re = '/^[A-Za-z]+\s*[A-Za-z]*(\*$)*/m';
$str = 'La*
Laura*
Laura Rese*
Laura Reseni
Laura Reseni*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);