package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]+\s*[A-Za-z]*(\*$)*`)
var str = `La*
Laura*
Laura Rese*
Laura Reseni
Laura Reseni*
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}