// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\w].*_\d+\.m[p4].$").unwrap();
let string = "gdgdf ddfdf dgdgd.mp4
gdgdg dgdgdg gdfdfd_2.mp4
mdhdgd gdgdgd hdydd_3.mp3
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}