package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w].*_\d+\.m[p4].$`)
var str = `gdgdf ddfdf dgdgd.mp4
gdgdg dgdgdg gdfdfd_2.mp4
mdhdgd gdgdgd hdydd_3.mp3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}