import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w].*_\\d+\\.m[p4].$";
final String string = "gdgdf ddfdf dgdgd.mp4\n"
+ "gdgdg dgdgdg gdfdfd_2.mp4\n"
+ "mdhdgd gdgdgd hdydd_3.mp3\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}