re = /^J(ohn|\.(?= D\.)|(?= D )) D(aniel|\.)? Martin I{3}$/
str = 'John D. Martin III'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end