using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^J(ohn|\.(?= D\.)|(?= D )) D(aniel|\.)? Martin I{3}$";
string input = @"John D. Martin III";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}