$re = '/^J(ohn|\.(?= D\.)|(?= D )) D(aniel|\.)? Martin I{3}$/';
$str = 'John D. Martin III';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);