const regex = /\s{4}\/\*\*\n\s+\*\s@see\s[a-zA-Z\.#\(,\*\s\)]+\*\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s{4}\\\/\\*\\*\\n\\s+\\*\\s@see\\s[a-zA-Z\\.#\\(,\\*\\s\\)]+\\*\\\/', 'g')
const str = ` /**
* @see duke.webapp.struts.DukeDispatchAction#executeDefault(org.apache.struts.action.ActionMapping,
* org.apache.struts.action.ActionForm, javax.servlet.http.HttpServletRequest,
* javax.servlet.http.HttpServletResponse)
*/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}