import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s{4}\\/\\*\\*\\n\\s+\\*\\s@see\\s[a-zA-Z\\.#\\(,\\*\\s\\)]+\\*\\/";
final String string = " /**\n"
+ " * @see duke.webapp.struts.DukeDispatchAction#executeDefault(org.apache.struts.action.ActionMapping,\n"
+ " * org.apache.struts.action.ActionForm, javax.servlet.http.HttpServletRequest,\n"
+ " * javax.servlet.http.HttpServletResponse)\n"
+ " */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}