re = /\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?"/m
str = '
<img src="https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g" /> '
subst = '.gif"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result