use strict;
my $str = '
<img src="https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g" /> ';
my $regex = qr/\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?"/mp;
my $subst = '.gif"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";