$re = '/\.gif\?([^=]+=[^=]+&)+[^=]+(=[^=]+)?"/m';
$str = '
<img src="https://media.giphy.com/media/m7jzopL8Dm1kA/giphy.gif?cid=ecf05e4785d70ac4724a4083945ea6171d95688bf6a8a282&rid=giphy.gif&ct=g" /> ';
$subst = ".gif\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;