re = /packages\/(?<package>[^\/]+)\/(?<version>[^\/]+)\/(?<file>[^\/]+)/m
str = 'packages/a-bc/1.0.0b2414.dev7+fde6133/a.bc-1.0.0b2414.dev7+fde6133-py3-none-any.whl
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end