import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "packages/(?<package>[^\\/]+)/(?<version>[^\\/]+)/(?<file>[^\\/]+)";
final String string = "packages/a-bc/1.0.0b2414.dev7+fde6133/a.bc-1.0.0b2414.dev7+fde6133-py3-none-any.whl \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}