using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"packages/(?<package>[^\/]+)/(?<version>[^\/]+)/(?<file>[^\/]+)";
string input = @"packages/a-bc/1.0.0b2414.dev7+fde6133/a.bc-1.0.0b2414.dev7+fde6133-py3-none-any.whl
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}