$re = '/\w+([-+.\']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*/m';
$str = 'Abby.O’connor@test.org
Abby.O\'connor@test.org
AbbyO\'&^%@#$connor@test.org
abbyoconnor@test.org
abbyoor@te.org
abb.yoor@t.e.s.rg
abby!oconnor@test.org
ab#byoconnor@test.org
abb$yoconnor@test.org
abb*yoconnor@test.org
abbyoc-onnor@test.org
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);