use strict;
my $str = 'Abby.O’connor@test.org
Abby.O\'connor@test.org
AbbyO\'&^%@#$connor@test.org
abbyoconnor@test.org
abbyoor@te.org
abb.yoor@t.e.s.rg
abby!oconnor@test.org
ab#byoconnor@test.org
abb$yoconnor@test.org
abb*yoconnor@test.org
abbyoc-onnor@test.org
';
my $regex = qr/\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}