const regex = /\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([-.]\w+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+([-+.\']\\w+)*@\\w+([-.]\\w+)*\\.\\w+([-.]\\w+)*', 'gm')
const str = `Abby.O’connor@test.org
Abby.O'connor@test.org
AbbyO'&^%@#\$connor@test.org
abbyoconnor@test.org
abbyoor@te.org
abb.yoor@t.e.s.rg
abby!oconnor@test.org
ab#byoconnor@test.org
abb\$yoconnor@test.org
abb*yoconnor@test.org
abbyoc-onnor@test.org
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}