// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"field: "(.*?)""#).unwrap();
let string = "{field: \"platformID\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'ne', 'cn', 'gt', 'lt']},
sortFunc: 'number'
},
{field: \"platformName\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
cellTemplate: '<a href=\"#/clemove/clemoveDetaiPlatform/{{row.platformID}}\" translate=\"{{row.platformID}}\"></a>',
search: {operator: ['eq', 'cn']},
},
{field: \"platformOwnerTEF\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
sortFunc: 'number'
},
{field: \"platformOwnerZTE\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
sortFunc: 'number'
},
{field: \"platformVendor\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
sortFunc: 'number'
},
{field: \"platformE2E\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"platformInternalDependency\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"platformServiceDependency\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"platformPreferedMoveDate\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"platformUnpreferedMoveDate\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"platformAdditionalTool\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"platformVM\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"platformCommunicationMatrix\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"stateName\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
cellFilter: 'translate',
},
{field: \"modeName\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},
{field: \"relocationgroupName\",
displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",
quickSearch: true,
search: {operator: ['eq', 'cn']},
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}