# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"field: \"(.*?)\""
test_str = ("{field: \"platformID\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'ne', 'cn', 'gt', 'lt']},\n"
" sortFunc: 'number'\n"
"},\n"
"{field: \"platformName\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" cellTemplate: '<a href=\"#/clemove/clemoveDetaiPlatform/{{row.platformID}}\" translate=\"{{row.platformID}}\"></a>',\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformOwnerTEF\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
" sortFunc: 'number'\n"
"},\n"
"{field: \"platformOwnerZTE\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
" sortFunc: 'number'\n"
"},\n"
"{field: \"platformVendor\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
" sortFunc: 'number'\n"
"},\n"
"{field: \"platformE2E\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformInternalDependency\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformServiceDependency\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformPreferedMoveDate\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformUnpreferedMoveDate\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformAdditionalTool\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformVM\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"platformCommunicationMatrix\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"stateName\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
" cellFilter: 'translate',\n"
"},\n"
"{field: \"modeName\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},\n"
"{field: \"relocationgroupName\",\n"
" displayName: \"T_MOVE_DASHBOARD_COLDEF_INCIDENTID\",\n"
" quickSearch: true,\n"
" search: {operator: ['eq', 'cn']},\n"
"},")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.