#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "field: "(.*?)""
Local $sString = "{field: "platformID"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'ne', 'cn', 'gt', 'lt']}," & @CRLF & _
" sortFunc: 'number'" & @CRLF & _
"}," & @CRLF & _
"{field: "platformName"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" cellTemplate: '<a href="#/clemove/clemoveDetaiPlatform/{{row.platformID}}" translate="{{row.platformID}}"></a>'," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformOwnerTEF"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
" sortFunc: 'number'" & @CRLF & _
"}," & @CRLF & _
"{field: "platformOwnerZTE"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
" sortFunc: 'number'" & @CRLF & _
"}," & @CRLF & _
"{field: "platformVendor"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
" sortFunc: 'number'" & @CRLF & _
"}," & @CRLF & _
"{field: "platformE2E"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformInternalDependency"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformServiceDependency"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformPreferedMoveDate"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformUnpreferedMoveDate"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformAdditionalTool"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformVM"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "platformCommunicationMatrix"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "stateName"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
" cellFilter: 'translate'," & @CRLF & _
"}," & @CRLF & _
"{field: "modeName"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"}," & @CRLF & _
"{field: "relocationgroupName"," & @CRLF & _
" displayName: "T_MOVE_DASHBOARD_COLDEF_INCIDENTID"," & @CRLF & _
" quickSearch: true," & @CRLF & _
" search: {operator: ['eq', 'cn']}," & @CRLF & _
"},"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")