// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"@var\s*(?<type>[\w\\<>,]+(?:\[\])?(\s*\|\s*[\w\\<>,]+(?:\[\])?)*)").unwrap();
let string = "/**
* @var Ahoj[] | null $var
*/
/**
* @var Ahoj
*/
/**
* @var Ahoj[]
*/
/**
* @var Ahoj | array<string,array<int,int>> |fdgtdf[] $var
*/
/**
* @var Ahoj | null[] $var
*/
/**
* @var Ahoj[] | null[] $var
*/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}