package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@var\s*(?<type>[\w\\<>,]+(?:\[\])?(\s*\|\s*[\w\\<>,]+(?:\[\])?)*)`)
var str = `/**
* @var Ahoj[] | null $var
*/
/**
* @var Ahoj
*/
/**
* @var Ahoj[]
*/
/**
* @var Ahoj | array<string,array<int,int>> |fdgtdf[] $var
*/
/**
* @var Ahoj | null[] $var
*/
/**
* @var Ahoj[] | null[] $var
*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}