$re = '/@var\s*(?<type>[\w\\\\<>,]+(?:\[\])?(\s*\|\s*[\w\\\\<>,]+(?:\[\])?)*)/';
$str = '/**
* @var Ahoj[] | null $var
*/
/**
* @var Ahoj
*/
/**
* @var Ahoj[]
*/
/**
* @var Ahoj | array<string,array<int,int>> |fdgtdf[] $var
*/
/**
* @var Ahoj | null[] $var
*/
/**
* @var Ahoj[] | null[] $var
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);