$re = '/^[0-9]{13}\\\\n/m';
$str = '
5038614652\\n
9202032561428\\n
^[0-9]{13}
^[0-9]{10,}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);